Planet PDF Forum Archive

Planet PDF ForumWowsers! This is page is old, head to the LIVE Planet PDF Forum. It features more than 10 conferences, covering everything from beginner to in-depth developer and pre-press discussions. If you wish to continue... one & two archive covers 1999-2011 (160,000 pages).

New Forum | Previous | Next | (P-PDF) Developers

Topic: ParseFDF and Servlet Samples Dont Work
Conf: (P-PDF) Developers, Msg: 80380
From: bmuni
Date: 1/29/2003 02:24 AM


I've tried to get the ParseFDF servlet sampler to work and apparently I am running into a problem where the server is not finding the servlet at all. It seems like a few people have been experiencing similar kinds of problems.

I am using jakarta-tomcat-4.0.4 as my application server, in stand alone mode. I have the jfdftk.jar file appropriately place in the servers classpath (which could be either commons/lib directory or under the WEB-INF/lib directory on tomcat.

My servlet is located in the appropriate packaged path under the application directory ie jakarta-tom.../webapps/munix/WEB-INF/classes/munix/ and the web.xml file points to this correctly. The ParsePDF.pdf file has its submit button set to correlate with the web.xml file. eg



(for some reason these tags brackets are missing when I preview them here ...hmmm.. looks fine in the web.xml file, Anyway...)

and the action attribute of the form is set to: parseFDF

This configuration is correct and works with all my servlets on the system, but the darn thing won't even find the servlet.

If I place the place the parseFDF.pdf file in the PDFs subdirectory under the application root and run it using the appropriate link eg http://munix/munix/parsePDF, I get a 404 with the following: message :

message /PDFs/parseFDF
description The requested resource (/PDFs/parseFDF) is not available.

(So it is trying to find the servlet in the PDFs subdirectory where the PDF is located) ... strange...

Now if I move the PDF file into the applications root directory (one level up) I get the following exception when I try to access the servlet:

java.lang.UnsatisfiedLinkError: GetTempFilename
at com.adobe.fdf.FDFDoc.GetTempFilename(Native Method)
at com.adobe.fdf.FDFDoc.(
at munix.ParseFDF.doPost(

line 46 references the following in the code:

FdfInput = new FDFDoc(data);

So apparently there is a problem when the FDFDoc object is being created. Now it seems that I remember reading in the set up documentation that this API jfdftk.jar is totally platform independant unlike the earlier version (fdfkt.jar). So the set up just says to add the jfdftk.jar to the servers class path and everything should be okay. I did this and removed the deprecated APIs (fdftk.jar and the jfdftk.dll) from the system and tried running the servlet again. I still get the same kinds of problem. I am wondering if this toolkit is buggy. Does anyone know. Is there a better solution that is not going to be too expensive.

Thanks in advance
Beaumont Muni

PDF In-Depth Free Product Trials Ubiquitous PDF

Debenu Aerialist

The ultimate plug-in for Adobe Acrobat. Advanced splitting, merging, stamping, bookmarking, and link...

Download free demo

Debenu PDF Tools Pro

It's simple to use and will let you preview and edit PDF files, it's a Windows application that makes...

Download free demo

Five visions of a PDF Day

In the world of PDFs or as we like to say Planet (of) PDF, a year isn't a real PDF year without an intense few days of industry knowledge sharing.

May 15, 2018
Platinum Sponsor

Search Planet PDF
more searching options...
Planet PDF Newsletter
Most Popular Articles
Featured Product

Debenu PDF Aerialist

The ultimate plug-in for Adobe Acrobat. Advanced splitting, merging, stamping, bookmarking, and link control. Take Acrobat to the next level.


Adding a PDF Stamp Comment

OK, so you want to stamp your document. Maybe you need to give reviewers some advice about the document's status or sensitivity. This tip from author Ted Padova demonstrates how to add stamps with the Stamp Tool along with related comments.