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Acrobat Forms 101

This paper provides an overview of Adobe Acrobat forms creation. It is based on my experi-
ence as a trainer working with both large and small corporations.

It is my experience that many students come into class not even thinking about the forms 
capability of Acrobat. They are there to learn how to make better-looking PDFs, and haven’t 
had time or interest to look the powerful forms capability of Acrobat. After they see what forms 
can do, they say “Wow” and go back and try to implement forms at work.

I’ve often thought about why so few people walk into class with forms creation in mind. I have a 
few theories:

• Forms are someone else’s job. Many of my students are technical writers. Traditionally, 
forms have been created by the human resources and finance departments. With more 
forms going on the web, and more people filling out forms, I think technical communicators 
could be a big help in improving the effectiveness of forms.

• Forms are boring. Forms are often an afterthought, and the last thing done before a pro-
cess rolls out or is modified. Forms really are a key to making a new or improved process a 
success. Interactive forms are definitely more fun to create than paper-based ones.

• Forms belong to the web team. They certainly can be, but web designers need good direc-
tion to produce effective forms. Without effective direction, web-based forms can be as 
incomprehensible as the old paper-based ones. Again, this is an area where technical com-
municators can play a big role.

This presentation is titled Acrobat Forms 101. It is a very basic view of Acrobat forms. If you 
are new to Acrobat forms or thinking of implementing forms, this presentation is for you.

1 Where do forms come from?
There are three ways to create a form:

• Convert an existing form.

• Create a shell in another application and add fields with Acrobat.

• Use Web Capture to turn an html form into an Acrobat form. 
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Convert an existing form
Many companies want to start by converting existing forms to PDF. A great tool for this conver-
sion is OmniForm from ScanSoft (formerly Caere). See www.caere.com for more information. 
This tool works for paper and electronic forms. There are probably similar tools available, but 
this is one I am familiar with. It converts JetForms to PDF.

Create a shell
This is a common way to begin if you do not have an existing form. You create a shell form 
using your favorite page layout or word processing software, and then use Acrobat to lay in 
fields in the shell. It’s this method that we will spend the most time with today because it 
explains what the automated tools like OmniForm are doing.

Use Web Capture
Acrobat 4.0’s “Web Spider” application is surprisingly powerful. Not only does it turn regular 
html pages into PDF, but it also will transform an html form into an Acrobat form. We will take a 
look at an example at the end of this presentation.

2 Convert an existing form
Although you can start with an electronic form, such as JetForm, we will start from paper. After 
all, if we can convert paper to an Acrobat form, then converting an electronic form with 
already-delineated fields should be easier. (It is.)

An evaluation form
Let’s say that one of the presenters at the PDF 2000 Conference sent his materials in on 
paper, and we want to turn it into an electronic form.

http://www.caere.com
http://www.caere.com
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By using OmniForm, we can easily turn this piece of paper into an electronic form. Below is a 
scan of the original.

As you can see at a glance, this is a form. It has boxes to check off and information to fill in. 

To begin, you start OmniForm, put the form in our scanner and import the scan. You select 
options in OmniForm to automatically create form fields. The figure below shows what the raw 
scan in OmniForm looks like.

For the sake of clarity, let’s just focus on the square in the bottom.
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The software identified fields and generally made a good guess at what kind of field they 
should be: text, check box and so on. The text looks a little rough, but OmniForm generally 
clears that up pretty well, too.

The next step is to choose File > Save As and select PDF. The same form when saved as PDF 
looks like this.

Although it doesn’t show up here, OmniForm created check boxes and text fields in the right 
positions.If necessary, you can use Acrobat to change form properties or to change a field 
type.

All in all, it is a simple, clean conversion.

To convert JetForms, open the JetForm up in OmniForm and choose File > Save As and 
choose PDF.

3 Create a form from a shell
Many large organizations, including most major corporations, run on forms. But when you 
mention the word “form,” which entity comes to mind first? Oh, yes, the government. They are 
here to help you, and a form is required.

The IRS was an early adopter of PDF-based forms. It’s easy to see why. Isn’t it much easier to 
download a tax form from the web than to run down to the library or post office and hope they 
have your form in stock? Not to mention that the web, unlike your local library, never closes.

Generally, the IRS forms are meant to be printed out and filled in by hand, just like the old 
days. In fact, many companies are doing the same thing with their “electronic” forms. Printable 
forms save some paper (or at least transfers the cost to the user), and can be a good way for 
people to become familiar to the idea of working with forms electronically.

To create a shell such as a standard tax form, you create the basic form in your favorite page 
layout or word processing application. Common ones include FrameMaker, PageMaker, InDe-
sign, XPress, and Microsoft Word. You then PDF the application file, and open the “formless” 
application in Acrobat to add fields.

Instead of creating your own form, for practice you can download a 1040EZ form from the 
www.irs.gov site. That’s the form we will be using here. It’s the same principle as creating your 
own, except that the U.S. taxpayer has already paid to have this shell created.

5. Was the presentation worth your time and money?

6. How did you hear of this event?

7. Any general comments?

Please add me to your mailing list for a free information kit and more resources.
seminars, speakingI like what I heard today and I want more. Please send details on Dan's:

private consulting.to my group and/or

Company name:Your name:

City:Address:

ZIP: Tel:State: -

Please print clearlyemail:

Pl h d thi l ti t d it t P P bli hi PO B 8206 S t B b

( )

✘

✘

✘

Carl Young DigiPub Solutions Corp.
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The shell
The form we will use in this example is the 1040EZ form. It’s a two page form, but the only part 
we are about is Page One.

Do you want $3 to go to this fund? �

Taxable interest. If the total is over $400, you cannot use
Form 1040EZ.

Department of the Treasury—Internal Revenue Service
Form Income Tax Return for Single and

Joint Filers With No Dependents1040EZ 1999 OMB No. 1545-0675

Spouse’s social security number

NoYes
Note. Checking “Yes” will not change your tax or reduce your refund.Presidential

Election
Campaign
(See page 12.)

CentsDollars
Total wages, salaries, and tips. This
should be shown in box 1 of your
W-2 form(s). Attach your W-2 form(s).

1

1 , .Attach
Copy B of
Form(s)
W-2 here.
Enclose, but
do not staple,
any payment.

2
2

Add lines 1, 2, and 3. This is your adjusted gross
income.
Can your parents (or someone else) claim you on their return?5Note. You

must check
Yes or No.

Yes. No.

5 , .
Subtract line 5 from line 4. If line 5 is larger than
line 4, enter 0. This is your taxable income. �

6
6 , .

Payments
and tax

Earned income credit (see page 15).

7
7 , .

Tax. Use the amount on line 6 above to find your tax
in the tax table on pages 24–28 of the booklet. Then,
enter the tax from the table on this line.

10

10 , .
Refund If line 9 is larger than line 10, subtract line 10 from

line 9. This is your refund.
11a

11a .

If line 10 is larger than line 9, subtract line 9 from line
10. This is the amount you owe. See page 21 for
details on how to pay. .

I have read this return. Under penalties of perjury, I declare that to the best of my knowledge and belief, the
return is true, correct, and accurately lists all amounts and sources of income I received during the tax year.

Sign
here
Keep copy for
your records.

For Disclosure, Privacy Act, and Paperwork Reduction Act Notice, see page 23.

Income

,

,

.

.,

Cat. No. 11329W

�
4

4

12

12

If a joint return, does your spouse want $3 to go to this fund? �

Your social security number

Add lines 7 and 8a. These are your total payments.

8a

8a .
9 9 , .

Enter your Federal income tax withheld from box 2 of
your W-2 form(s).

Type $

Unemployment compensation, qualified state tuition
program earnings, and Alaska Permanent Fund
dividends (see page 14).

3

3 , .

Use
the
IRS
label
here

Your first name and initial

Apt. no.Home address (number and street). If you have a P.O. box, see page 12.

City, town or post office, state, and ZIP code. If you have a foreign address, see page 12.

If a joint return, spouse’s first name and initial

Last name

Last name

Amount
you owe

b Routing number
Account
number

c Type:
Checking Savings

�

Enter amount
from worksheet
on back.

If single, enter 7,050.00.
If married, enter 12,700.00.
See back for explanation.

Your signature

Your occupationDate

Spouse’s signature if joint return. See page 11.

Spouse’s occupationDate

Have it
directly
deposited! See
page 20 and
fill in 11b,
11c, and 11d.

d

Yes No

�

1 2 3 4 5

6 7 8 9 10

�

�

(99)

Nontaxable earned income: enter type and amount below.b

1999 Form 1040EZ

For
Official
Use
Only

�

IMPORTANT!
You must enter

your SSN(s) above.

� �
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The procedure

Now it is time to create our own form. We will not complete all the fields, but you may wish to 
do so on your own later.

Note: Choose View > Show Forms Grid to help align the form fields.

Formatting fields
We will now create the Social Security number fields, and use a special format so users can 
only enter a a Social Security number with the correct number of digits.

Note:  Use Appearance > Text options in the Field Properties box to change the look of text.

Step Action
1 Open 1040EZ.pdf in Acrobat.

2 Select the Form tool.

3 Marquee (click and drag) a box in the First Name area of the 
form.

4 Name the field FirstMI.

5 Type should be Text.

6 Click OK.

7 Use the Form tool to create another field.

8 Name this field Last.

9 Finish the name and address information part of the form, 
excluding Social Security numbers.

Step Action
1 Marquee the first Social Security box.

2 Name the field SS1.

3 Choose Format > Special > Social Security Number.

4 Click OK.

5 Complete the spouse Social Security Box. Name it SS2.
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Create check boxes
Now we will make some boxes easy to check off by creating buttons.

Note: You can duplicate form fields by holding down the Ctrl key (Option key on the Mac) and 
dragging the field to the new location.

Note: Control-A selects all fields.

Create a list box
Now we will add a list of choices to the form.

Step Action

1 Using the Form tool, marquee around the Yes box across from 
“Do you want $3 to go to this fund?”

2 Name this field Prez1 and make the type Radio Button.

3 Under Options, make the style Check and the Export Value 
Yes.

4 Copy the Prez1 field and paste it over the No box.

5 Double-click on the box to open it.

6 Change the export value to No.

7 Click on the Hand tool and test your work.

8 Finish the spouse Presidential Election Campaign Yes/No 
fields.

Step Action

1 Marquee with the From tool around the box named Type in 8b, 
Earned Income Tax Credit.

2 Name the field Credit and make the type List Box.

3 Under Options, enter Minister in the Item list and export value.

4 Click Add.

5 Add Household Employee and Inmate to the list.

6 Add the text Choose One and make it the first item.

7 Click OK.

8 Select the Hand tool and check the field.
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Restrict data entry in field
To keep users from entering invalid data, it is useful to validate the data entered in the field.  

Make Fields Calculate

JavaScript
Acrobat form fields are powered by JavaScript. Let’s note here that JavaScript is not Java the 
programming language. JavaScript is a scripting language that is embedded into HTML. Java 
the programming language is an object-oriented language that developers use to create 
applets and applications that run on a server and are transmitted to the desktop. It looks a lot 
like C++ and you need to be a programmer to use it.

JavaScript, on the other hand, runs only on the client and is fairly easy to learn.

Step Action

1 Using the Form tool, marquee the $ amount box to the right of 
the Type box in 8b.

2 Name the Field Earned$ and make the type Text.

3 Under the Format tab, choose Number, set Decimal Places to 
0 and Currency Symbol to Dollar.

4 Click on the Validate tab.

5 Enter a range from between 1 and 10,000.

6 Click OK.

7 Select the Hand tool and test the number field with valid and 
invalid amounts.
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Add a sum field
We will use Acrobat’s built-in JavaScript editor to add the income on our 1040EZ file.

Use JavaScript to create a custom field calculation
We don’t have time to make the entire form interactive, so we will skip to the bottom. We will 
assume our tax rate is 28 percent, and use a JavaScript to calculate the amount of tax due.

Step Action

1 Use the Form tool to make number fields in lines 1, 2 and 3 of 
the Income section. Name the fields Income1, Income2 and 
Income3. For decimal Places choose 2 and for Currency 
Symbol choose Dollar.

2 Using the Form tool again, marquee a box around the boxes in 
question 5.

3 Name the field IncomeSum.1 and make it a number field.

4 Click on the Calculate tab.

5 Select Value is the sum (+) and choose Pick.

6 Select the income fields and click Add and then Done.

7 Click OK and test the fields.

8 Save your work as 1040EZ_Work.pdf.

Step Action
1 Use the Form tool to create a field over the boxes in Line 12 

Amount you owe.

2 Name the field AmountDue. For decimal Places choose 2 and 
for Currency Symbol choose Dollar.

3 Click on the Calculate tab.

4 Click on Edit.
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Tip: For more information, see Help > Forms JavaScript Guide.

Add a Reset Button

It’s good to have one button that clears a form.

5 Enter the text:
 var a=this.getField(“IncomeSum.1”);
event.value = a.value *.28;
as shown in the box below.

6 Click OK.

7 Click OK again.

8 Select the Hand tool and make sure the tax is calculating 
correctly.

9 Save the file and close it.

Step Action
1 Open 1040EZ_work.pdf.

2 Select the Form tool.

3 Marquee a box in the white space of the upper right corner.

4 Name the field Reset and choose Button as type.

5 Click on Appearance and format the button border, background 
and text.

6 Click on Options.

7 Under Layout, choose Text over icon.

8 Enter Reset Form in the Text field.

9 Click on Actions and select Mouse Up and Add.

10 Under Type, choose Reset Form. By default, all fields are reset.

Step Action
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Submitting data
Acrobat can submit form information via E-mail, in a structured text file called Forms Data For-
mat, or as HTML. A server-side script can parse the form data and put it into a database.

11 Click Set Action.

12 Click OK and test the form.

Step Action

1 Open 1040EZ.pdf, fill in some data and scroll to the bottom of 
the first page.

2 Select the Form tool and marquee around the For Official Use 
Only boxes.

3 Name the Field Submit and make the type button.

4 Change the Border and Background colors to red and the text 
to black.

5 Select Options and choose Text over icon layout.

6 Enter Submit in the Text field.

7 Select Actions and select Mouse Up and Add.

8 Choose Submit Form.

9 Choose Select URL.

10 Enter mailto:test@digipubcorp.com.

11 Select HTML Form under Export format.

12 Click OK.

13 Click Set Action.

14 Click OK and test the form.
Note: The data will not send unless your computer is 
connected to the Internet.

Step Action
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4 Use Web Capture
Acrobat’s built-in Web Capture application is a great way to archive web sites. In addition, it 
creates PDF forms on the fly from html forms.

To create the PDF 2000 Conference registration form below, I simply opened up the registra-
tion url and made a PDF of secure order form. (Note: in the case of the PDF 2000 Conference, 
and perhaps your own company, you need special permission to get past the secure firewall.)

The long field names are a bit incomprehensible, but they work fine. You can move them 
around to other locations, or change the properties of a field in Acrobat.

Note:  Remember that when you PDF login screens, you can save the login data with the 
form. That may or may not be a good thing!
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